The iCal feature - does it work?

A member has said that they can't get the "Export to your calendar" feature (where you can copy the details of a specific hike into the calendar on your device(s)) to work for the iCal version on his Apple devices. Is anyone else trying to use this feature? If so, does it work for you or do you have problems?

Was working on April 23, but now when I try and add it to my iCloud Calendar, it pops up with an error message. Will keep trying once I RSVP for more events...

Nic,

Thanks. When you did it on April 23 were you trying to add it to something different (just to your device I guess)? In other words, has it stopped working because you moved your calendar from a single device to the Cloud?

No, I'm pretty sure I'm not doing anything different. I generally check this site from my computer as it's not very mobile friendly. They need to add a mobile version. It works if I choose to add to the calendar on my Mac (not the iCloud calendar), but then it doesn't push to my iPhone. If I add it from my iPhone, it appears to work, but I will need to try with a different event, to see if adding to the icloud calendar via the phone pushes to my MBP.

OK, thanks. Please let me know when you've worked out what works and what doesn't. Details of error messages would be good too so I can put a useful bug report in to Groupspaces.

Comments from anyone else using, or trying to use, the calendar functions are also very welcome!

Ok, so the iCal feature appears to add only to the device that you use it on. Adding via iPhone doesn't give an error message, but doesn't update to the iCal on my MBP. Manually adding an event to the iPhone calendar does push to the MBP and vice versa.

There must be some error in the file from the GroupSpaces iCal feature - the error message that pops up is - 

"Access to “A hard+ hike from DB to Mui Wo” in “Calendar” in account “iCloud” is not permitted.
The server responded:
“403” to operation CalDAVWriteEntityQueueableOperation."

It then gives you two choices as buttons - "Go Offline" or "Revert to Server" - Clicking revert to server makes the event disappear from iCal. Clicking "Go Offline" puts it into the Calendar (under iCloud Calendar), but doesn't push it through to my iPhone. Plus if you right-click on the event "Get Info", and you click any of the buttons at the bottom of the pop-up (Maybe, Decline, Accept), the above error message pops up again. Clicking "Decline" makes the event grey on the iCal, but doesn't seem to change RSVP.

So, just to be clear, the behaviour is different depending on whether you attempt to add the event to your iCloud via an iPhone or via a MacBookPro (I'm guessing that's what "MBP means")?

If attempting to add on the iPhone then the event adds to the iPhone but doesn't get promulgated to iCloud and hence not to other devices.

If attempting to add on the MBP then you first get the error message, and then can only get it to stick in the MBP calendar by "going Offline".

In both cases (iPhone and MBP, correct?) trying to "Get Info" fails as described?

Thanks again for your help narrowing this down.

Yes - correct, except the "Get Info" bit, this is only on Macbook Pro (MBP). You can see the info, but the error box comes up again when you click one of the options on the bottom - Maybe, Decline, Accept. If you just close the window no error box pops up. These options are not available when I look at the info from manually added events on the MBP nor if I look at GroupSpaces added events on the iPhone. I assume these options are supposed to link to your RSVP status on the event but don't seem to change anything (on the site) when clicked (apart from giving you the error message).

OK - thanks. I've put this in as a bug report to Groupspaces.

Nic,

Regrettably, I'm getting "we can't reproduce it so it must be Apple's problem" as the response from Groupspaces.

Could I ask you to do one more test - could you do what you did above on Thrusday's event also on Friday's? I wonder if the problem is that Thursday's event is "invite only" and hence there are problems accessing it from a device (or server) which isn't logged in to Groupspaces under the ID of someone who is invited.

And could you confirm that you're seeing a clickable "Maybe" option? That shouldn't be there, because none of our events have the Maybe response enabled.

Thanks.

Ok. Just did a search on the error string and it appears that it is a known bug with iCal but no official fix appears to be available. (https://discussions.apple.com/thread/2591009?start=105&tstart=0). People appeared to have it cropping up under different circumstances, one guy had an issue when his calendar was shared with his wife's icloud account/calendar.

I have stopped the error message by going to "iCal>Preferences" and changing the default calendar, but it still doesn't seem to push to the iPhone. I exported Dave's friday hike (without signing up). Clicking accept from the "Get info" still does nothing WRT the event RSVP, but the error message no longer pops up. So all in all it seems that nothing has changed except I no longer get the error message. 

OK, so error message still occuring when I hit Calendar>Refresh All or Refresh for last event added using the iCal feature, whether I've RSVPd or not. So changing the default Calendar seems to just remove the error message when adding event.  

I tried with all the events this week - Tues plus the two on Fri. I'm guessing that Dave's fri hike is invite-only, as the email has an invite code? I can now RSVP from this event page directly, where as last week the RSVP button had disappeared for invite-only events.

Note when I said without signing up - that was for the hike. I have signed in to the site.

Ah, OK , so although Groupspaces caanot reproduce it, it does indeed appear to be a known iCal problem. I guess that closes that trouble ticket then!

I see some suggested (partial) remedies here... http://support.apple.com/kb/ts3985


Hong Kong Hikers

Powered by GroupSpaces · Terms · Privacy Policy · Cookie Use · Create Your Own Group